Community Forum ArtWork Work in Progress Soggiorno Cycles

Stai visualizzando 18 post - dal 1 a 18 (di 18 totali)
  • Autore
    Post
  • #425379
    Stenji
    Membro
    @stenji

    Ciao a tutti,

    prima che diventi matta, qualcuno può spiegarmi perchè in fase di renderizzazione non mi visualizza l’insieme di cornici che invece sono visibilissime nel 3D e nell’anteprima di render????

    il file è un .fbx importato, tutte le componenti risultano visibili e renderizzabili nella barra laterale a destra…non so dove sbattere la testa!

    #425390
    Harvester
    Moderatore
    @harvesterAssociato

    Strano. Dovresti controllare, se non l’hai già fatto, la renderizzabilità dell’oggetto, le proprietà dell’oggetto (pannello Object | Cycles Settings), nonchè i nodi del materiale (se hai utilizzato ill nodo Light Path per la trasparenza). Le normali le avrai già verificate, penso. Controlla i Layer che hai abilitato per il rendering (vedi esempio qui sotto dove ho “dimenticato” di selezionare anche il layer con Suzanne). Altro non mi viene in mente.

    layer_renderability

    #427642
    perepepe77
    Partecipante
    @perepepe77

    Molto strana questa cosa…

    #460742
    Stenji
    Membro
    @stenji

    Un paio di giorni dopo ho provato a reinserire le stesse cornici in un altro file…stesso discorso. Visibili nell’anteprima, spariscono nel render finale.

    Ora controllo i settaggi dei materiali e i layer…non avendoli modificati, non c’ho pensato nemmeno a controllarli.

    Vi faccio sapere!!

    #460781
    perepepe77
    Partecipante
    @perepepe77

    Visto che sono semplici cornici, potresti farci spulciare il .blend, contenenti solo loro, magari in privato se non qui.

    #460797
    Stenji
    Membro
    @stenji

    Assolutamente si! come faccio a mandarvelo???

    #460798
    andcamp
    Moderatore
    @andcampAssociato
    #460800
    Stenji
    Membro
    @stenji

    Via ho caricato il file delle cornici singolo e il file completo del progetto.

    Magari ho fatto degli errori iper grossolani nell’importarlo…bho…

    🙂 mi affido a voi!

    https://www.wetransfer.com/downloads/0d3b13e10894bbebe7c8d99c28243b9520160127162840/ca4840f63812ec6a2e92dee6136dea8920160127162840/dad850

    #460804
    BAdmin
    Amministratore del forum
    @blenderitalia

    Controlla su outliner di non aver accidentalmente cliccato sulla macchina fotografica. Se su outline la macchina fotografica (icona) è grigia su un oggetto, questo non viene renderizzato.

    #460834
    perepepe77
    Partecipante
    @perepepe77

    Bella questa!!!! Guardando i tuoi screen all’inizio dicevo…ma i quadri i vista top sono da tutt’altra parte che sul muro. Bene, apro il tuo file, li sposto a mano nella parete, il render in viewport è ok…ma quando si pigia f12 le cornici sono dotate di vita propria e si spostano all’esterno!!!! Hahaha sono possedute!!!

     

    #460835
    Stenji
    Membro
    @stenji

    ecco esatto, mi ero scordata di dirvi anche questa…si spostano da sole! anche se blocchi una a una la loro posizione!!!

    #460840
    Stenji
    Membro
    @stenji

    Sto notando ora, che ogni cornice ha un’animazione in sè….può dipendere da quello?

    #460843
    Stenji
    Membro
    @stenji

    ok…svelato l’arcano…ora me le renderizza!!! quindi era colpa delle animazioni legate a ogni cornice!!

    Grazie a tutti comunque per l’aiuto e il tempo dedicato..

    PS: se avete scaricato il file completo…e avete notato impostazioni errate da qualche parte, materiali composti male, o cose così…me lo fate sapere??? 😀

    #460844
    perepepe77
    Partecipante
    @perepepe77

    Non so cosa tu abbia messo per bloccarli, ma hai dato una chiave di animazione a tutti i componenti, cancellandole si risolve.

    #460845
    Stenji
    Membro
    @stenji

    l’animazione c’era già prima credo, perchè avevo appunto provato a bloccarle, selezionandole una alla volta, con il lucchetto nelle posizioni in cui le sistemavo (su x,y,z)…ma continuavano a spostarsi comunque…

    #460846
    Harvester
    Moderatore
    @harvesterAssociato

    Effettivamento ho notato che tutti i quadri hanno un keyframe impostato al fotogramma 1 per Location, Rotation e Scale.

    Una volta rimossi tutti i keyframe (nel caso, selezioni tutti i quadri poi vai nella vista Animation – Screen Layout – e cancelli tutti i keyframe; nel Outliner seleziona la vista per Orphan Data e togli la spunta su tutte le Actions per rimuoverle completamente dal file) e spostati i quadri sulla parete all’interno del soggiorno il rendering mi sembra corretto, con i quadri visibili. Solo per curiosità, posso chiederti se l’intera scena è importata da 3DS Max?

    Sulla rimozione dei Keyframe questo link su StackExchange potrebbe esserti utile: Delete animation of object

    Facci sapere se così si risolve l’arcano mistero.

    #460847
    Stenji
    Membro
    @stenji

    Sì, gli oggetti li prendo da un sito che imposta le scene per 3DS max…effettivamente tolte le animazioni, come mi dicevi anche tu, torna tutto al suo posto!!

    🙂

    #460855
    Harvester
    Moderatore
    @harvesterAssociato

    Dai un’occhiata agli oggetti curva qui sotto evidenziati in quanto a parte quella del tavolo con le sedie, tutte le altre sono posizionate a distanze notevoli dal centro della scena. Se non ti servono puoi spostarle su un layer diverso, o rimuoverne in fase di rendering (macchina fotografica).

    distant_objects

Stai visualizzando 18 post - dal 1 a 18 (di 18 totali)
  • Devi essere connesso per rispondere a questo topic.