Community Forum Supporto Utenti Supporto hardware Problema con Blender e la scheda grafica

Stai visualizzando 7 post - dal 1 a 7 (di 7 totali)
  • Autore
    Post
  • #886094
    Plasticolando
    Partecipante
    @danielebocchetti63

    Ciao, ho un problema di questo tipo, vediamo se c’e’ una soluzione e se mi potete aiutare a trovarla.

    Premetto che in Blender sono ancora un principiante…quindi andateci piano  😀
    Uso Blender 3.6.5 ma penso sia lo stesso se uso la 4. E’ molto lento anche con Mesh non troppo complesse, allora per vedere se c’e’ qualche impostazione che si possa modificare per velocizzare un pochino la grafica, sono andato in Edit-Preferences-System nelle opzioni Cycles Render Devices (che sono CUSA – OptiX – HIP – oneAPI), tutte mi danno un msg : No compatible GPUs found for Cycles. Required GPU with compute capability 3.0
    Il mio PC e’ un Asus F555Q con processore AMD 10  16MBRam  SSD 256GB e “purtroppo” una schifosissima Radeon R5/6/7 che se non ho capito male e’ incorporata nella CPU.

    Sistema Operativo Linux Mint 20.3
    Se vado in terminale e digito:

    lspci | grep -i vga

    mi esce…

    00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] (rev ca)
    se successivamente digito…

    glxinfo | grep “OpenGL”
    mi esce…
    OpenGL vendor string: AMD
    OpenGL renderer string: AMD CARRIZO (DRM 3.35.0, 5.4.0-182-generic, LLVM 12.0.0)
    OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.2.6
    OpenGL core profile shading language version string: 4.60
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.2.6
    OpenGL shading language version string: 4.60
    OpenGL context flags: (none)
    OpenGL profile mask: compatibility profile
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.2.6
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
    OpenGL ES profile extensions:

    Le informazioni confermano che la GPU AMD Radeon R5/R6/R7 è correttamente riconosciuta dal sistema e che OpenGL è abilitato e funzionante.
    Ecco cosa confermano i risultati:
    • Output di lspci: L’output di
      lspci | grep -i vga
    • mostra che la scheda grafica AMD/ATI Radeon R5/R6/R7 è riconosciuta come “VGA compatible controller”.
    • Output di glxinfo: L’output di
      glxinfo | grep “OpenGL”
    • fornisce informazioni dettagliate sull’implementazione di OpenGL nel sistema. Mostra che la GPU è correttamente riconosciuta come “AMD CARRIZO” e che il driver Mesa è utilizzato per l’implementazione di OpenGL. La versione di OpenGL è 4.6 ed è supportato sia il profilo core che il profilo di compatibilità.


    Dato che la GPU supporta OpenGL e sembra essere configurata correttamente….io qui mi sono impantanato….c’e’ chi mi puo’ dare qualche dritta ??

     

    P.S. Ho gia impostato la Viewport Shading su “Solid Mode” ma senza risolvere.

     

    E’ lento in tutto. I render non li faccio in quanto Blender mi serve…anzi mi servirebbe per creare figurini, anime, veicoli etcc avendo come hobby il modellismo, quindi mi basta fermarmi alla parte di creazione della mesh e poi salvarla in STL per poi darla in pasto alla printer 3D. Ma anche solo con mesh che non sono chissa cosa rallenta in maniera oscena. Giusto come esempio. Una mesh con 784k Vertices 2,3M di Edges 1,5M faces 1,5M triangles, se anche in Object mode non ci sono problemi, appena attivo la edit….mi si siede letteralmente.
    Un altra mesh con 425k Vertices 1,2M Edges 850kFaces 850k Triangles, in Edit non si siede ma va a scatti.

    Grazie.

    #886138
    andcamp
    Moderatore
    @andcampAssociato

    Buondì,
    Avevi controllato la gestione delle attività per controllare il consumo della RAM? Le schede video integrate purtroppo non sono molto adatte all’utilizzo dei software di modellazione 3D (specie se in un portatile)
    Per un eventuale render, avevi provato ProRender, più compatibile con le schede Radeon?  https://www.amd.com/en/products/graphics/software/radeon-prorender/blender.html

    #886207
    Plasticolando
    Partecipante
    @danielebocchetti63

    Provato ad aprire una mesh e attivando Statistic, mi dice Vertices 784k – Edges 2,3M – Faces 1,5M – Triangles 1,5M e aprendo il Monitor di Sistema di Linux, mi dice che la Ram occupata in quel momento e’ poco sopra il 40% (Ho 16GB installati). e oltre a Blender avevo 2 Browsers aperti. Quindi presumo che la memoria non c’entri nulla.

    Il ProRender non ho mai provato ad usarlo anche perche’ quando si tratta di modellazione e sculpting delle mesh in Blender, le prestazioni dipendono maggiormente dalla CPU e dalla GPU integrata rispetto al motore di rendering utilizzato. Radeon ProRender è specificamente un motore di rendering, quindi il suo impatto sulle prestazioni di modellazione e sculpting delle mesh dovrebbe essere limitato. Comunque la mia domanda iniziale e’ sempre quella, perche’ Blender non vede la GPU.

    #886344
    andcamp
    Moderatore
    @andcampAssociato

    “Comunque la mia domanda iniziale e’ sempre quella, perche’ Blender non vede la GPU.”
    Se Blender non vedesse la GPU non si vedrebbe neanche la 3D View, non si vedrebbe neanche Blender; un computer non può visualizzare qualcosa senza il supporto di una qualsiasi scheda grafica.
    Diciamo più che altro che non vede la GPU integrata per renderizzare in Cycles (Infatti c’è anche scritto “Cycles render devices” nelle opzioni “System” delle preferenze)

    #886354
    Plasticolando
    Partecipante
    @danielebocchetti63

    Quindi ricapitolando, Cycles e’ usato solo per il rendering (che per l’uso che faccio di Blender non mi serve), mentre l’altro msg che mi esce quando apro le schede CUDA Optix HIP e oneAPI che dice Requires NVIDIA GPU with compute capability 5.0 and NVIDIA driver versione 470 or newer, e’ sempre legato al discorso di Cycles e anche qui dipende dal fatto che la mia GPU e’ integrata nella CPU e non e’ una scheda a se ??

    Ergo……….troppo poca potenza elaborativa del mio HW, cambia quella ciofeca di PC che usi. Corretto ??

    #886360
    andcamp
    Moderatore
    @andcampAssociato

    Al momento mi sembra sia corretto così

    #886387
    Plasticolando
    Partecipante
    @danielebocchetti63

    OK grazie. Chiudo la discussione come risolta…..anche se in effetti dal lato pratico devo trovare i soldini per un bel PC performante. 🙁

Stai visualizzando 7 post - dal 1 a 7 (di 7 totali)
  • Devi essere connesso per rispondere a questo topic.